English versions:

TimeSlice 3 Requires OS 10.4 or above.

Older version for older OSes:
TimeSlice 2.8 (English Version).  Requires OS 10.2 or above.




Deutsche Version / German versions:

TimeSlice D-3.4 Läuft ab OS 10.4 oder neuer.

Ältere Programmversion:
TimeSlice D-2.8.8 (Deutsche Version). Läuft ab OS 9 und ab OS X 10.2.